Register
Join Cyclechaos! Motorcycles Wiki Forum Recent Posts Search Today's Posts Mark Forums Read
Cycle Chaos > Cyclechaos Forums > Manufacturers > Honda > 1980 Honda CB650 Charging problem

1980 Honda CB650 Charging problem

This is a discussion on 1980 Honda CB650 Charging problem within the Honda forums, part of the Manufacturers category; I have a '80 CB650. The bike runs like a champ!! Only problem is it isn't charging the battery. I ...


Reply
 
LinkBack Thread Tools
Old 05-13-2011   #1
Junior Member
 
Join Date: May 2011
Posts: 3
Cool 1980 Honda CB650 Charging problem

I have a '80 CB650. The bike runs like a champ!! Only problem is it isn't charging the battery. I have replaced the stator, R/R, and bought a new battery. I have followed all steps in the fault finding chart that can be found at the following link, and everything has passed it's respective tests as outlined:

http://www.electrosport.com/technical-resources/library/diagnosis/pdf/fault-finding-diagram.pdf

At this point I am totally lost as to what the problem can be. I have a strong background in electronics (specifically with cars/trucks) which is making it even more frustrating.

Any ideas would be greatly appreciated!!

Last edited by GeneralSmirnoff; 05-13-2011 at 04:09 PM.
GeneralSmirnoff is offline   Reply With Quote
Old 05-19-2011   #2
Junior Member
 
Join Date: May 2011
Posts: 2
Default

Sorry can't help but I have a problem starting my Honda CB 650C bike after it has been running for a while. It struggles to turn over, any ideas??
Beginner is offline   Reply With Quote
Old 05-19-2011   #3
Junior Member
 
Join Date: May 2011
Posts: 3
Default

When you say "running" do you mean after riding for a while?? or do you mean you start it in your driveway and let it run??
GeneralSmirnoff is offline   Reply With Quote
Old 05-19-2011   #4
Junior Member
 
Join Date: May 2011
Posts: 19
Default

you have a couple things to check.

one. you said that you replaced the stator.. does that mean it isnt still bad? is the pick up working? are the flywheel magnets defective, it could be producing some current, but not enough??

Rectifier could still be bad.. wiring defective? is there a ground somewhere? is the ground grounded properly? Corrosion will prevent a good charge from reaching the battery.


Just throwing out ideas.. hope it helps.

Last edited by stmanser; 05-19-2011 at 01:51 PM.
stmanser is offline   Reply With Quote
Old 05-27-2012   #5
Junior Member
 
Join Date: May 2012
Posts: 2
Post

Quote:
Originally Posted by GeneralSmirnoff View Post
I have a '80 CB650. The bike runs like a champ!! Only problem is it isn't charging the battery. I have replaced the stator, R/R, and bought a new battery. I have followed all steps in the fault finding chart that can be found at the following link, and everything has passed it's respective tests as outlined:

http://www.electrosport.com/technical-resources/library/diagnosis/pdf/fault-finding-diagram.pdf

At this point I am totally lost as to what the problem can be. I have a strong background in electronics (specifically with cars/trucks) which is making it even more frustrating.

Any ideas would be greatly appreciated!!
check the field rotor resistance between the copper rings. Should have 4.6 to 5.3 ohms resistance .. that is the #1 issue with those types of systems .. I have rebuilt thosusands of those ld119 rotors. I have been rebuilder of motorcycle rotors and stators over 25 years... always glad to help when i can. just email me and i will help you trouble shoot it .
timparrott316 is offline   Reply With Quote
Old 07-01-2012   #6
Junior Member
 
Join Date: Jul 2012
Posts: 1
Default My Experience

I have the same bike and have had problems as well, one thing to make sure to check is continuity of the rotor to ground. My rotor tested fine when cold, but when the bike heated up, the rotor grounded out and stopped charging. Tim Parrots rebuilds are great, just got one to replace said rotor. One other thing to keep in mind is the rotor can ruin the r/r, my bad rotor ruined the brand new r/r.
mdirk is offline   Reply With Quote
Reply

Bookmarks

Tags
1980, cb650, charging, honda, problem

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1980 honda cb 750 blinker and tail light problem jello Honda 6 08-03-2011 12:56 PM
New owner of 1980 Honda CB650, have questions. Inspector Honda 3 05-04-2011 03:47 PM
1982 honda cb750 charging problem mikey11211 Motorcycle Discussion 0 06-21-2008 12:08 PM
Honda CB650 battery not charging Speed R Honda 2 05-08-2006 04:41 AM
honda gl1200 charging problem NaBiLaH a Honda 2 03-21-2006 04:11 AM


All times are GMT -5. The time now is 11:53 PM.


Powered by vBulletin®