Register
Join Cyclechaos! Motorcycles Wiki Forum Recent Posts Search Today's Posts Mark Forums Read

yz80

This is a discussion on yz80 within the Motocross forums, part of the Types of Bikes category; gday all i got a problem with my 84 yz80 she hasent run for a good couple of years now ...


Reply
 
LinkBack Thread Tools
Old 03-09-2006   #1
Junior Member
 
Join Date: Dec 2008
Posts: 11
Default yz80

gday all i got a problem with my 84 yz80 she hasent run for a good couple of years now i bought it of a bloke not goin when i try 2 start it will only run for about 30 seconds and its only just tickin over iv tryed fresh fuel new plug and cleaning out the carbie but nothin works it semes to be geting fuel and has good spark but when i take the spark plug out it has alot of black oil on it im runing the fuel mix at 30:1 when u try to open the throtle it just dies could it be that because it hasent run for so long the bore is just gumed up with alot of oil and just needs to be cleaned out ? it has good compresion any help would be apriciated because my legs geting real sore kickin it and im get real fustrated thanxs mick
shane t is offline   Reply With Quote
Old 03-10-2006   #2
Junior Member
 
Join Date: Dec 2008
Posts: 6
Default yz80

Well Mick it could be a number of issues causing the problem. An old 80 like that I'd suspect rings though you say compression is okay you really need to use a guage and get the actual figure and check that against the specs. It don't take much of a loss to do in such a small bore. Make sure your plug is the correct heat range and the plug wire might be bad. Be certain the oil you're using is the right type. It could be your float is out of adjustment or your fuel line is partially clogged or kinked (fuel starvation) Lot's of other possibilities, you might want to consult a Yamaha mechanic and cover his palms with a bit of silver as a last resort. Most MX riders using YZ80's know all the symptoms.
Pearlfx is offline   Reply With Quote
Old 03-11-2006   #3
Junior Member
 
Join Date: Dec 2008
Posts: 16
Default yz80

Random things to check:

Spark plug gap?

Reed Valve?

Carbon buildup on the cylinder head?

All I have right now, it's been a while since I've had a Yammer Hammer two stroke.
triq033 is offline   Reply With Quote
Old 03-11-2006   #4
Junior Member
 
Join Date: Dec 2008
Posts: 17
Default yz80

I had a similar problem and Mine is a 2000. You should run it more like 32:1 to get more fire, and defenetly check the Gap in the spark.
leelee is offline   Reply With Quote
Old 03-11-2006   #5
Junior Member
 
Join Date: Dec 2008
Posts: 8
Default yz80

ei Mick
after all these months of kicking... how's it going mate?
what was the problem?
angelosdad is offline   Reply With Quote
Old 03-12-2006   #6
Junior Member
 
Join Date: Dec 2008
Posts: 11
Default yz80

still aint got her going lost intrest workin on me klx now
shane t is offline   Reply With Quote
Reply

Bookmarks

Tags
yz80

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Rear Wheel for 1998 YZ80 -- HELP PLEASE pullum4545 YZ 0 10-30-2009 04:24 PM
question about 1987 yz80? Pockpock YZ 2 01-20-2009 08:32 AM
yz80 front suspension help dylan YZ 1 12-26-2008 11:30 AM
how big are YZ80 dirt bikes? livthedreamxrideitup YZ 2 12-24-2008 12:55 AM
my 1983 yz80 is leaking coolant? nathan v YZ 2 12-17-2008 08:19 PM


All times are GMT -5. The time now is 11:18 PM.


Powered by vBulletin®